Redis - Fehler bei apt update && apt upgrade


  • Irgendwann die Tage ist mit bei Aktualisieren meiner Hetzner VMs aufgefallen, das der Webserver der meine NodeBB-Foren ausliefert, eine Warnung schmeißt. Das war kein Problem, weil alles wie erwartet lief, aber so was stört. Man schaut dann immer drauf und denkt da ist was kaputt. Also - fixen!

    Der relevante Teil des Problemes

    Job for redis-server.service failed because the service did not take the steps required by its unit configuration.
    See "systemctl status redis-server.service" and "journalctl -xe" for details.
    invoke-rc.d: initscript redis-server, action "restart" failed.
    

    Ok, der systemd Dienst will nicht. Nachgeschaut, der war bei mir disabled, weil ich den gar nicht für die beiden Foren nutzte. Ich hatte zwei eigene angelegt und das läuft auch alles einwandfrei.

    Ok, ein ☕ Dann stand der Plan fest. Von einem Forum den systemd disabled, den Inhalt in den systemd Dienst

    /lib/systemd/system/redis-server.service
    

    kopiert. Die Original Daten habe ich mir zur Sicherheit vorher kopiert. Den Dienst wieder enabled und gestartet. Mittlerweile war das Forum gecrasht, einmal neu gestartet - läuft alles wieder!

    Jetzt kommt auch bei

    apt update && apt upgrade
    

    kein Fehler mehr, logisch. Der Dienst existiert jetzt auch und kann nach einem Update usw. auch neu gestartet werden.

    Und wieder was gelernt 🙂