Skip to content

Ubiquiti ER-X - DMZ

Verschoben OpenWRT & Ubiquiti ER-X
  • Wie ich schon geschrieben hatte, betreibe ich das bei mir zu Hause so.

    DMZ_network_diagram_1_firewall.svg.png
    Bildquelle

    Im LAN sind alle vertrauenswürdigen Geräte. In der DMZ befinden sich alle Geräte, die ich als nicht vertrauenswürdig einstufe. Also, Playstation, TV usw.

    Meine Konfiguration sieht so aus /etc/config/network

    config interface 'loopback'
            option ifname 'lo'
            option proto 'static'
            option ipaddr '127.0.0.1'
            option netmask '255.0.0.0'
    
    config globals 'globals'
            option ula_prefix 'fdd5:a13b:e125::/48'
    
    config interface 'lan'
            option type 'bridge'
            option ifname 'eth0.1'
            option proto 'static'
            option ipaddr '192.168.1.1'
            option netmask '255.255.255.0'
            option ip6assign '60'
            option ip6hint '0'
    
    config device 'lan_eth0_1_dev'
            option name 'eth0.1'
            option macaddr 'XX:xx:b9:a7:8b:23'
    
    config interface 'wan'
            option ifname 'eth0.2'
            option proto 'dhcp'
    
    config device 'wan_eth0_2_dev'
            option name 'eth0.2'
            option macaddr 'XX:xx:b9:a7:8b:24'
    
    config interface 'wan6'
            option ifname 'eth0.2'
            option proto 'dhcpv6'
    
    config switch
            option name 'switch0'
            option reset '1'
            option enable_vlan '1'
    
    config switch_vlan
            option device 'switch0'
            option vlan '1'
            option vid '1'
            option ports '1 2 3 6t'
    
    config switch_vlan
            option device 'switch0'
            option vlan '2'
            option ports '0 6t'
            option vid '2'
    
    config switch_vlan
            option device 'switch0'
            option vlan '3'
            option ports '4 6t'
            option vid '3'
    
    config interface 'DMZ'
            option ifname 'eth0.3'
            option proto 'static'
            option ip6assign '64'
            option ip6hint '1'
            list ipaddr '192.168.2.1/24'
    

    Das ergibt dann folgende Interfaces.

    pic009.png

    Auf dem Port eth4 befindet sich jetzt die DMZ. Ein DHCP Server verteilt Adressen. Auch die IPv6 Adresse wird ordentlich eingetragen.

    Weitere Beiträge zum Thema ER-X

    Vorstellung
    Installation
    Switch

  • Manjaro - KDE Plasma 6

    Linux
    1
    0 Stimmen
    1 Beiträge
    161 Aufrufe
    Niemand hat geantwortet
  • Hetzner Cloud - Volumes

    Allgemeine Diskussionen
    1
    0 Stimmen
    1 Beiträge
    907 Aufrufe
    Niemand hat geantwortet
  • Ubiquiti ER-X - iperf

    Verschoben OpenWRT & Ubiquiti ER-X
    2
    0 Stimmen
    2 Beiträge
    252 Aufrufe
    FrankMF

    Hier noch ein Test von DMZ / LAN und andersrum.

    frank@frank-MS-7C37:~$ iperf3 -c 192.168.5.15 Connecting to host 192.168.5.15, port 5201 [ 5] local 192.168.3.213 port 44052 connected to 192.168.5.15 port 5201 [ ID] Interval Transfer Bitrate Retr Cwnd [ 5] 0.00-1.00 sec 114 MBytes 952 Mbits/sec 314 153 KBytes [ 5] 1.00-2.00 sec 112 MBytes 937 Mbits/sec 259 205 KBytes [ 5] 2.00-3.00 sec 111 MBytes 929 Mbits/sec 210 212 KBytes [ 5] 3.00-4.00 sec 111 MBytes 934 Mbits/sec 235 202 KBytes [ 5] 4.00-5.00 sec 112 MBytes 936 Mbits/sec 263 153 KBytes [ 5] 5.00-6.00 sec 111 MBytes 935 Mbits/sec 255 209 KBytes [ 5] 6.00-7.00 sec 112 MBytes 937 Mbits/sec 313 129 KBytes [ 5] 7.00-8.00 sec 111 MBytes 932 Mbits/sec 296 209 KBytes [ 5] 8.00-9.00 sec 111 MBytes 934 Mbits/sec 258 208 KBytes [ 5] 9.00-10.00 sec 111 MBytes 934 Mbits/sec 292 201 KBytes - - - - - - - - - - - - - - - - - - - - - - - - - [ ID] Interval Transfer Bitrate Retr [ 5] 0.00-10.00 sec 1.09 GBytes 936 Mbits/sec 2695 sender [ 5] 0.00-10.00 sec 1.09 GBytes 935 Mbits/sec receiver iperf Done. frank@frank-MS-7C37:~$ iperf3 -R -c 192.168.5.15 Connecting to host 192.168.5.15, port 5201 Reverse mode, remote host 192.168.5.15 is sending [ 5] local 192.168.3.213 port 44058 connected to 192.168.5.15 port 5201 [ ID] Interval Transfer Bitrate [ 5] 0.00-1.00 sec 109 MBytes 911 Mbits/sec [ 5] 1.00-2.00 sec 109 MBytes 912 Mbits/sec [ 5] 2.00-3.00 sec 109 MBytes 912 Mbits/sec [ 5] 3.00-4.00 sec 109 MBytes 912 Mbits/sec [ 5] 4.00-5.00 sec 109 MBytes 912 Mbits/sec [ 5] 5.00-6.00 sec 108 MBytes 903 Mbits/sec [ 5] 6.00-7.00 sec 109 MBytes 912 Mbits/sec [ 5] 7.00-8.00 sec 109 MBytes 912 Mbits/sec [ 5] 8.00-9.00 sec 109 MBytes 912 Mbits/sec [ 5] 9.00-10.00 sec 109 MBytes 912 Mbits/sec - - - - - - - - - - - - - - - - - - - - - - - - - [ ID] Interval Transfer Bitrate Retr [ 5] 0.00-10.00 sec 1.06 GBytes 913 Mbits/sec 114 sender [ 5] 0.00-10.00 sec 1.06 GBytes 911 Mbits/sec receiver iperf Done.
  • 0 Stimmen
    1 Beiträge
    337 Aufrufe
    Niemand hat geantwortet
  • Ubuntu 20.04 Focal - Einrichtung

    Linux
    16
    0 Stimmen
    16 Beiträge
    2k Aufrufe
    FrankMF

    @reiner-zufall sagte in Ubuntu 20.04 Focal - Einrichtung:

    auto-save-session

    Interessant. Bitte poste, wenn Du was findest.

  • Nextcloud Talk

    Nextcloud
    5
    0 Stimmen
    5 Beiträge
    763 Aufrufe
    FrankMF

    All I needed to do was setting the permissions to 744 for the archive directory and the symlinks resolved correctly after a reboot of coturn

    My turnserver installation on Debian runs as the user turnserver and not as root, nor is the user turnserver in any group owning the letsencrypt directory.
    If your turnserver does run as root, it should be fine just adding execute permissions.

    I hope this helps some of you.
    Quelle: https://help.nextcloud.com/t/lets-encrypt-symlink-breaks-coturn-configuration/70166

    Was zum Testen die Tage....

  • VS Code - entferntes Verzeichnis einbinden

    Linux
    2
    0 Stimmen
    2 Beiträge
    376 Aufrufe
    FrankMF

    Mein kleines Projekt liegt auch noch auf gitlab.com. Man kann prima die beiden Dienste (VSCode & gitlab.com) verknüpfen.

    Eine Änderung, ein commit und dann

    git push origin master

    Und die Änderungen sind oben. Aber, ich stecke da noch ganz am Anfang der Lernkurve 😉

  • 0 Stimmen
    1 Beiträge
    774 Aufrufe
    Niemand hat geantwortet