Quartz64 - Modell B - Manjaro Image


  • Auf meine ganz normalen SD-Karten geflasht, die ich hier schon lange benutze.

    • SanDisk Extreme 64GB

    Warum ich das erwähne? Das wird noch wichtig. Nach dem Start kommt der early hook [plymouth], nichts besonderes. Abwarten, danach geht es irgendwann weiter. Machte er aber nicht, ich konnte die Wärme spüren, der B war dabei zu grillen. War schon sehr ordentlich warm 😞

    Ok, das bekomme ich so alleine nicht gefixt, als Profis fragen. Problem geschildert und folgende Antwort bekommen.

    that is a problem quartz64-b sdcard slot driver are still WIP so it currently can only read slower card

    Ok, wo bitte liegen hier noch langsame SD_Karten rum?? Ich hab noch eine gefunden, die kann man zwar nicht benutzen, weil es keinen Spaß macht aber für einen kurzen Test sollte es reichen. Image drauf und gestartet, sofort sieht man das es nicht mehr hängen bleibt wie vorher.

    Ich war dann in der Lage das Image zu installieren. Bitte aufpassen

    Passwörter nutzen nicht den deutschen Zeichensatz, auch wenn dieser eingestellt ist. Also bitte keine deutschen Sonderzeichen benutzen, kann man später ändern. Manjaro benutzt den richtigen Zeichensatz, nur der Installer nicht.

    Der Reboot geht nicht nach der Installation, kein Problem dafür hat man ja Taster am Quartz64 B.

    Danach eingeloggt und es läuft. Achso, ja wie gewohnt Wayland Session mit KDE Plasma Desktop.

    Und was ist das hier?

    [root@frank-pc ~]# lspci
    00:00.0 PCI bridge: Rockchip Electronics Co., Ltd RK3568 Remote Signal Processor (rev 01)
    01:00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd NVMe SSD Controller SM981/PM981/PM983
    

    Bäm! Da könnte ich jetzt das Root System drauf kopieren, dann den Bootvorgang anpassen und fertig. Mal schauen, was ich mache. Jetzt ist auch der Updatevorgang fertig, extrem langsam die SD-Karte 😉 Macht keinen Spaß.

    Auch das hier wird noch ausführlicher, die Tage. Soll ersta mal nur die wichtigsten Dinge auflisten, für andere die die Tage evt. einen B bekommen.


  • Ergänzung zur PCIe Schnittstelle, ein Geschwindigkeitstest crashte. Da fehlt noch ein Kernelpatch, der schon in Peters Entwicklungsumgebung drin ist, bei Manjaro aber noch fehlt. Es wird dran gearbeitet.

    Evt. ist der nächste Woche schon drin. Ich hoffe mal, weil mit der lahmen SD-Karte macht das so keinen Spaß.


  • Da die LAN-Schnittstelle auf Peter's Image und auf Manjaro Fehler hatte, habe ich mal nachgefragt woran das liegen könnte. Peter schickte dann einen Kernel Patch. Was mach ich damit? HELP

    -	phy-mode = "rgmii-id";
    +	phy-mode = "rgmii";
    

    Aber, da war nicht viel drin, das kann ich auch im .dtb File ändern. Dazu habe ich schon mal was geschrieben, bitte hier nachlesen.

    Ergebnis

    [root@frank-pc ~]# iperf3 -c 192.168.3.213
    Connecting to host 192.168.3.213, port 5201
    [  5] local 192.168.3.19 port 58848 connected to 192.168.3.213 port 5201
    [ ID] Interval           Transfer     Bitrate         Retr  Cwnd
    [  5]   0.00-1.00   sec   114 MBytes   954 Mbits/sec    0    636 KBytes       
    [  5]   1.00-2.00   sec   112 MBytes   944 Mbits/sec    0    636 KBytes       
    [  5]   2.00-3.00   sec   112 MBytes   944 Mbits/sec    0    636 KBytes       
    [  5]   3.00-4.00   sec   112 MBytes   944 Mbits/sec    0    636 KBytes       
    [  5]   4.00-5.00   sec   111 MBytes   933 Mbits/sec    0    636 KBytes       
    [  5]   5.00-6.00   sec   112 MBytes   944 Mbits/sec    0    636 KBytes       
    [  5]   6.00-7.00   sec   112 MBytes   944 Mbits/sec    0    636 KBytes       
    [  5]   7.00-8.00   sec   112 MBytes   944 Mbits/sec    0    636 KBytes       
    [  5]   8.00-9.00   sec   111 MBytes   933 Mbits/sec    0    636 KBytes       
    [  5]   9.00-10.00  sec   112 MBytes   944 Mbits/sec    0    636 KBytes       
    - - - - - - - - - - - - - - - - - - - - - - - - -
    [ ID] Interval           Transfer     Bitrate         Retr
    [  5]   0.00-10.00  sec  1.10 GBytes   943 Mbits/sec    0             sender
    [  5]   0.00-10.00  sec  1.09 GBytes   940 Mbits/sec                  receiver
     
    iperf Done.
    [root@frank-pc ~]# iperf3 -R -c 192.168.3.213
    Connecting to host 192.168.3.213, port 5201
    Reverse mode, remote host 192.168.3.213 is sending
    [  5] local 192.168.3.19 port 58852 connected to 192.168.3.213 port 5201
    [ ID] Interval           Transfer     Bitrate
    [  5]   0.00-1.00   sec   112 MBytes   941 Mbits/sec                  
    [  5]   1.00-2.00   sec   112 MBytes   942 Mbits/sec                  
    [  5]   2.00-3.00   sec   112 MBytes   941 Mbits/sec                  
    [  5]   3.00-4.00   sec   112 MBytes   942 Mbits/sec                  
    [  5]   4.00-5.00   sec   112 MBytes   942 Mbits/sec                  
    [  5]   5.00-6.00   sec   112 MBytes   941 Mbits/sec                  
    [  5]   6.00-7.00   sec   112 MBytes   942 Mbits/sec                  
    [  5]   7.00-8.00   sec   112 MBytes   942 Mbits/sec                  
    [  5]   8.00-9.00   sec   112 MBytes   942 Mbits/sec                  
    [  5]   9.00-10.00  sec   112 MBytes   942 Mbits/sec                  
    - - - - - - - - - - - - - - - - - - - - - - - - -
    [ ID] Interval           Transfer     Bitrate         Retr
    [  5]   0.00-10.00  sec  1.10 GBytes   943 Mbits/sec  366             sender
    [  5]   0.00-10.00  sec  1.10 GBytes   942 Mbits/sec                  receiver
     
    iperf Done.
    

    Problem sieht gelöst aus 🙂

  • Referenced by  FrankM FrankM 

  • Manjaro nutzt aktuell linux-quartz64

    [root@frank-pc ~]# pacman -S linux-quartz64
    Warnung: linux-quartz64-5.17.0-2 ist aktuell -- Reinstalliere
    Abhängigkeiten werden aufgelöst …
    Nach in Konflikt stehenden Paketen wird gesucht …
    
    Pakete (1) linux-quartz64-5.17.0-2
    
    Gesamtgröße des Downloads:             47,73 MiB
    Gesamtgröße der installierten Pakete:  69,58 MiB
    Größendifferenz der Aktualisierung:     0,00 MiB
    
    :: Installation fortsetzen? [J/n] n
    

    Dann gibt es noch linux-rc

    [root@frank-pc ~]# pacman -S linux-rc
    Abhängigkeiten werden aufgelöst …
    Nach in Konflikt stehenden Paketen wird gesucht …
    :: linux-rc und linux-quartz64 stehen miteinander in Konflikt (linux). linux-quartz64 entfernen? [j/N] N
    

    Im linux-rc steht aber kein dts für den Quartz64 Modell B zur Verfügung!?

    Dan meint, dann würde das Board den Kernel nicht laden können. Es ist also im Moment zu vermeiden den Kernel linux-rc zu installieren!


  • Neues zu dem Problem mit der SD-Karte. Hatte gestern einfach mal eine andere Karte des gleichen Typs ausprobiert, ging einwandfrei. Hmm, blöd wenn man nie weiß warum!?

    Dann gibt es den Kernel

    Linux version 5.17.0-3-MANJARO-ARM-Q64
    

    der mir beim Update von -2 auf -3 das ganze Sytem schrottet. Ich weiß leider nicht woran das liegt, habe die Logs mal an Dan und spikerguy geschickt. Mal sehen was dabei raus kommt. Im Moment auf -2 zu bleiben, könnte eine kluge Wahl sein.

    Im -3 ist nur der LAN Fix, den kann man auch per Hand im dtb ändern, ist nur ein Eintrag.

    -	phy-mode = "rgmii-id";
    +	phy-mode = "rgmii";
    
  • Referenced by  FrankM FrankM 

  • Heute kam dann der Kernel 5.19

    [root@frank-pc ~]# uname -a
    Linux frank-pc 5.19.0-rc1-0.2-MANJARO-ARM-Q64 #1 SMP PREEMPT Fri Jun 10 14:51:37 UTC 2022 aarch64 GNU/Linux
    

    am Anfang war es Version 5.19.0-rc1-0.1, aber was das? Keine Tastatur mehr? Häh.... Es ging nur noch der obere USB2 Port. Na gut, man weiß sich ja zu helfen, also einen USB Switch dran gehangen, alles wieder gut. Aber blöd ist das schon!? Außerdem war Sound über HDMI weg.

    So, warum? Ich nutze hier den Kernel

    linux-quartz64
    

    der wird im Manjaro Buildsystem direkt vom Peter gezogen. Und Peter arbeitet ja so, das er alles zum Mainline-Kernel hochladen kann usw.

    Der Audio Patch ist aber upstream noch nicht akzeptiert und für USB2 gibt es einen Patch, der wohl USB OTG aktivieren soll.

    USB2

    So in Peters dtb war die USB2 Schnittstelle auf OTG konfiguriert. Das macht aus irgendeinem Grund Ärger, ich habe das dann im dtb auf HOST umgestellt, danach war alles wieder wie vorher 🙂

    Schaut mal auf die Unterseite des B und ihr werdet folgendes finden.

    usb2_host.jpeg

    Fragt mich nicht, wozu man das braucht. Im Moment habe ich keine Ahnung. Steht bei mir aktuell auf HOST.

    Audio über HDMI

    Blöd, das das jetzt auf einmal nicht mehr geht. Dan hat dann ein paar Patche losgelassen, so das nun wieder Audio über HDMI funktioniert. So Desktop Betriebssysteme ohne Sound sind blöd - oder? 😉

    PCIe NVMe SSD

    Meine PCIe NVMe SSD funktionierte ja nicht, wenn man große Datenmengen kopierte crashte der Controller. Peter hat das gefixt, das ist seit 5.19 jetzt funktional. Und direkt als Root eingebunden.

    [root@frank-pc ~]# df -h
    Dateisystem    Größe Benutzt Verf. Verw% Eingehängt auf
    dev             1,7G       0  1,7G    0% /dev
    run             1,9G    1,3M  1,9G    1% /run
    /dev/nvme0n1p1  458G     11G  424G    3% /
    tmpfs           1,9G       0  1,9G    0% /dev/shm
    tmpfs           1,9G    220K  1,9G    1% /tmp
    /dev/mmcblk0p1  458M     42M  417M    9% /boot
    tmpfs           374M     48K  374M    1% /run/user/1000
    /dev/mmcblk0p2   59G    3,7G   52G    7% /run/media/frank/ROOT_MNJRO
    /dev/sda1       458G     11G  424G    3% /run/media/frank/777684c9-e74f-44b9-b491-694daafb9723
    

    Somit haben wir seit Kernel 5.19 PCIe NVMe SSD Unterstützung Yeah

    Und seit Kernel 5.19.0-rc1-0.2 geht auch wieder Audio über HDMI.

    Danke Dan für die Patches!

    Und Danke an den feinen Patch für PCIe NVMe an Peter!

  • 1
  • 3
  • 2
  • 4
  • 1
  • 2
  • 2
  • 3